Issue with KES Collections and Payouts, 18th March 2026

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

The service disruption impacting KES collections and payouts, have been resolved, and normal operations have been restored.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Mar 19, 2026 - 06:41 UTC

Identified

Dear Valued Customer,
We are currently experiencing service disruption, impacting KES collections and payouts.
The issue is under investigation and resolution is in progress.
Updates will be provided as more information becomes available.
We apologize for the inconvenience and appreciate your understanding.

Affected Services:
Affected Markets: Kenya
Posted Mar 18, 2026 - 16:47 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).