Resolved: Merchant Onboarding Service Issue

Incident Report for Flutterwave

Resolved

Dear esteemed Customers/Merchants,

We are pleased to inform you that the issue has been successfully resolved.

We thank you for your patience and understanding.


Affected Services:
Affected Markets: Global
Posted Oct 13, 2025 - 18:20 UTC

Identified

Dear Valued Customer,

We are currently investigating an issue impacting the merchant onboarding service. New merchants signing up at this time may be unable to complete their process.

Our technical team is actively working to resolve this as quickly as possible. We will provide an update as soon as we have more information

Affected Services:
Affected Markets: Global
Posted Oct 12, 2025 - 13:32 UTC
This incident affected: Flutterwave for Business (Flutterwave API).