Service Restored - Static Account Creation

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the disruption affecting the creation of accounts through one of our banking partners in Nigeria has been successfully resolved. We are monitoring the situation closely to ensure continued stability. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Nov 12, 2025 - 15:05 UTC

Identified

Dear Valued Customer,

We are currently experiencing a disruption affecting the creation of accounts through one of our banking partners in Nigeria.

The provider has confirmed the failure, and we are working with their team to restore the functionality.

We apologize for the inconvenience and will provide an update as soon as we have more information.

Affected Services:
Affected Markets: Nigeria
Posted Nov 06, 2025 - 20:10 UTC
This incident affected: Flutterwave Collections (Collections APIs).