Service Restored: Dynamic Account Generation (Nigeria)

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption impacting our dynamic virtual account generation capability has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Nov 29, 2025 - 20:51 UTC

Identified

Dear Valued Customer,

We are currently experiencing a service disruption impacting our dynamic virtual account generation capability. This issue originates from one of our providers in Nigeria.

Customers attempting to generate new accounts may experience failures or delays. Our technical team is actively working with our partner toward a resolution.

We apologize for the inconvenience and will provide an update shortly.

Affected Services:
Affected Markets: Nigeria
Posted Nov 29, 2025 - 06:48 UTC
This incident affected: Flutterwave Collections (Collections APIs).