Scheduled Maintenance: Interswitch (NGN) | 19th–20th September 2026

Scheduled for Sep 19, 21:00 UTC  -  Sep 20, 06:00 UTC

Update

This maintenance has commenced.
Posted Sep 19, 2026 - 21:00 UTC

Scheduled

Please be informed of scheduled maintenance on Interswitch from Saturday, 19th September 2026, at 09:00 PM UTC to Sunday, 20th September 2026, at 06:00 AM UTC.

During this period, you may experience temporary disruptions when processing NGN transactions on card.

We apologise for any inconvenience this may cause and appreciate your patience and understanding.
Posted Sep 16, 2026 - 12:59 UTC
This scheduled maintenance affects: Flutterwave Collections (Collections APIs).