[ZAR] Service Restored: Capitec Payments Experiencing Timeouts

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with capitec has been successfully. Thank you for your patience and understanding.

Affected Services:
Affected Markets: South Africa
Posted Sep 16, 2026 - 11:28 UTC

Identified

Dear Valued Merchant,

Payments through Capitec in South Africa are currently experiencing timeouts, which may prevent some transactions from being completed successfully. We are working with the provider to resolve the disruption and restore normal service. Further updates will be shared as progress is made.

We apologize for the inconvenience and appreciate your patience and understanding.

Affected Services:
Affected Markets: South Africa
Posted Sep 16, 2026 - 08:17 UTC
This incident affected: Flutterwave Collections (Checkout JS).