Service Restored: Pay With Bank Transfers (Nigeria)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the delays with bank transfers and name verification in Nigeria due to a service disruption from one of our partner provider has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Mar 02, 2026 - 16:30 UTC

Identified

Dear Valued Customer,

Some users may experience delays with bank transfers and name verification in Nigeria due to a service disruption from one of our partner provider.

Our team is monitoring the situation as the provider works on a resolution. Thank you for your patience.

Affected Services:
Affected Markets: Nigeria
Posted Mar 02, 2026 - 11:29 UTC
This incident affected: Flutterwave Collections (Collections APIs).