Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2026 - 20:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 21, 2026 - 14:43 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 21, 2026 - 14:41 UTC
Scheduled
Dear Valued Merchant,
To further enhance the security and reliability of our payment platform, we will be carrying out a scheduled infrastructure upgrade during the period below. This maintenance is part of our ongoing commitment to providing a more secure and resilient service.
Maintenance Window Date: Saturday, 25 July 2026 Time: 8:00 PM UTC Duration: Approximately 30 minutes
Expected Impact During the maintenance window, you may experience temporary service interruptions or intermittent availability affecting:
Payment collections Payouts and transfers Merchant Dashboard access Airtime and bill payment services API integrations Virtual account services
Transactions initiated during this period may fail or time out. We recommend retrying any unsuccessful transactions after the maintenance has been completed.
To minimize disruption, we recommend avoiding: Time-sensitive transactions during the maintenance window
Our technical teams will closely monitor the activity to ensure services are restored as quickly as possible, and normal operations are expected to resume immediately after the maintenance window.
We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding as we continue to improve the security and reliability of our platform.
Thank you for choosing Flutterwave.
Posted Jul 21, 2026 - 14:40 UTC
This scheduled maintenance affects: Flutterwave Payouts (Payouts APIs), Flutterwave for Business (Flutterwave API, Settlements, Bill Payments (Airtime), Bill Payments (Cable TV)), and Flutterwave Collections (Collections APIs, Virtual Account Numbers).