Scheduled Maintenance, M-PESA KENYA, September 21st, 2025

Incident Report for Flutterwave

Update

Affected Services:
Affected Markets: Kenya
Posted Sep 22, 2025 - 10:45 UTC

Resolved

Dear Valued Customer,

We are pleased to inform you that the maintenance has been completed. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Sep 22, 2025 - 10:45 UTC

Identified

Dear Valued Customer,

Please be informed about a system maintenance on JamboPay Kenya M-Pesa Service.

Maintenance Schedule:
Start: Sunday, September 21st 2025, 09:30 PM UTC
End: Monday, September 22nd 2025, 00:30 AM UTC

During this time, all M-Pesa services will be unavailable .

We apologize for any inconvenience this may cause and appreciate your understanding.

Affected Services:
Affected Markets: Kenya
Posted Sep 19, 2025 - 11:34 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).