Service Alert: Intermittent Send Login and Transfer Issues

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting Send login, transfers, and profile information has been resolved, and normal service has been restored.

We apologize for the inconvenience experienced and appreciate your continued understanding.
Posted Sep 20, 2026 - 18:35 UTC

Investigating

Dear Valued Merchant,

We are currently experiencing a recurrence of the disruption affecting Send, which may cause intermittent timeouts when logging in, completing transfers, or loading profile information. Our team is actively investigating the issue and working to restore normal service. Further updates will be shared as progress is made.

We apologize for the inconvenience and appreciate your patience and understanding.
Posted Sep 20, 2026 - 10:17 UTC