Service Restored [Nigeria]: Issues with USSD payments

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the service timeout with USSD services has been successfully resolved.

We thank you for your patience and understanding.


Affected Services:
Affected Markets: Nigeria
Posted May 07, 2026 - 08:32 UTC

Identified

Dear Valued Customer,

We are experiencing a service timeout with USSD services. We are working to get your the service up again and will update you shortly. We are sorry for the trouble and appreciate your patience.

Affected Services:
Affected Markets: Nigeria
Posted May 07, 2026 - 08:09 UTC
This incident affected: Flutterwave Collections (Collections APIs).