Service Alert: Flutterwave for Business (F4B) - Issue with Login

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting F4B login has been successfully resolved.

Thank you for your patience and understanding.
Posted Aug 13, 2026 - 22:54 UTC

Investigating

Dear Valued Merchant,

We are currently experiencing a service disruption affecting access to F4B. As a result, some merchants are unable to log in to the platform.

Our team is actively working to restore normal access. We are monitoring the situation closely and will provide further updates as soon as more information becomes available.

We apologize for the inconvenience and appreciate your patience and understanding.
Posted Aug 13, 2026 - 21:15 UTC