We are pleased to inform you that the issue preventing you from downloading payout receipts on your F4B dashboard has been resolved. You should now be able to access and download your receipts without any problems.
We understand this caused inconvenience, and we sincerely apologize for the disruption.
Thank you for your patience and understanding.
Affected Services: F4B Login & Dashboard Affected Markets: Global
Posted Aug 20, 2025 - 10:10 UTC
Investigating
Dear Valued Customer,
We are currently experiencing an issue preventing merchants from downloading payout receipts on our business application (F4B) dashboard. Our team is actively investigating and working to resolve this as quickly as possible.
We apologize for any inconvenience this causes and appreciate your patience.
We will provide an update as soon as we have one.
Affected Services: F4B Login & Dashboard Affected Markets: Global
Posted Aug 20, 2025 - 09:00 UTC
This incident affected: Flutterwave for Business (Dashboard).