[Zambia] Service Restored: Temporary payment delays

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the transaction delays experienced by some customers in Zambia has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Zambia
Posted Jun 26, 2026 - 08:41 UTC

Identified

Dear Valued Customer,

We are experiencing a temporary disruption with one of our payment partners in Zambia, which is causing transaction delays for some of our customers. Our team is working closely with them to get everything running smoothly again. We apologize for this disruption to your day and appreciate your understanding.

Affected Services:
Affected Markets: Zambia
Posted Jun 25, 2026 - 12:22 UTC
This incident affected: Flutterwave Collections (Collections APIs).