[Kenya] Service Restored: M-Pesa Payment Delays

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the delays with payments due to an issue with our external provider has been successfully resolved.

We thank you for your patience and understanding.


Affected Services:
Affected Markets: Kenya
Posted May 02, 2026 - 21:28 UTC

Identified

Dear Valued Customer,

We are aware that some users are facing issues with payments. This is due to an issue with our external provider. We are working with them to get things back to normal soon. We apologize for any inconvenience caused.

Affected Services:
Affected Markets: Kenya
Posted May 02, 2026 - 20:52 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).