[Nigeria] Service Restored: Issues with Card Payments

Incident Report for Flutterwave

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 16:43 UTC

Update

Dear Valued Customer,

Some users may face difficulties completing card transactions due to an ongoing disruption with our external card processing partner. Our team is monitoring the issue closely to ensure a swift fix. We apologize for the inconvenience and thank you for your patience.
Posted Jun 23, 2026 - 08:26 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2026 - 08:26 UTC
This incident affected: Flutterwave Collections (Collections APIs).