[Egypt] Service Restored: Issues with Payment Collections

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the delays with local payment collections in Egypt due to a technical issue with one of our payment partners has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets:
Posted Apr 24, 2026 - 08:04 UTC

Identified

Dear Valued Customer,

We are currently seeing some delays with local payment collections due to a technical issue with one of our payment partners. Some users may be affected by this. Our team is investigating and working on a quick fix. We apologize for the trouble and thank you for your patience.

Affected Services:
Affected Markets:
Posted Apr 23, 2026 - 23:05 UTC
This incident affected: Flutterwave Collections (Checkout JS).