Test Incident 14th May

Incident Report for Flutterwave

Resolved

Closing Test ServBot

Affected Services: Servman Bot
Affected Markets: Global
Posted May 14, 2024 - 10:44 UTC

Investigating

Testing ServBot

Affected Services: Servman Bot
Affected Markets: Global
Posted May 14, 2024 - 10:43 UTC
This incident affected: Shared Services (Servman).