We are happy to confirm that the E-Wallet service has been fully restored and is now operating as normal.
Thank you for your patience and understanding. We apologize again for any inconvenience you may have experienced.
Affected Services: CheckOut by MoMo Tanzania Affected Markets: Tanzania
Posted Aug 27, 2025 - 07:33 UTC
Investigating
Dear Valued Customer,
E-Wallet service is still experiencing an outage. We are continuing to work with our provider to resolve the issue as quickly as possible.
We apologize for any inconvenience this causes and appreciate your continued patience. We will provide another update as soon as we have more information.
Thank you,
Affected Services: CheckOut by MoMo Tanzania Affected Markets: Tanzania
Posted Aug 26, 2025 - 12:09 UTC
Identified
Dear Valued Customer,
We are currently experiencing a service outage on E-Wallet service. Our team is working with the provider to resolve this as quickly as possible.
We will keep you updated on the progress of resolution. We apologize for any inconvenience this may cause and thank you for your patience and understanding.
Affected Services: CheckOut by MoMo Tanzania Affected Markets: Tanzania
Posted Aug 26, 2025 - 10:08 UTC
This incident affected: Flutterwave Collections (Collections APIs).