[Nigeria] Service Restored: NGN Payment Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jul 06, 2026 - 18:23 UTC

Update

Please be informed that this has been resolved. Transactions are now processing fine. We are monitoring to confirm stability. Further update will be provided.

Affected Services:
Affected Markets: Nigeria
Posted Jul 06, 2026 - 17:38 UTC

Identified

Dear Cherished Merchant,

We are currently experiencing a disruption affecting NGN payments for some customers due to an issue with an external service provider.

Our team is actively investigating the issue and working with the provider to restore normal service as quickly as possible. We will share further updates as more information becomes available.

We sincerely apologize for the disruption and appreciate your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jul 06, 2026 - 17:26 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).