Scheduled Maintenance on Mastercard Gateway in North America Region, 4th September 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that this maintenance has been completed.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: US
Posted Sep 04, 2025 - 10:57 UTC

Identified

Dear Valued Customer,

We would like to inform you about an upcoming system maintenance on our Mastercard Gateway. This will affect services in the North America (NA) region.

The maintenance is scheduled to take place on Thursday, September 4, 2025.
Start: 07:30 AM UTC
End: 09:30 AM UTC

During this time, you may experience brief transaction timeouts or failures. The total disruption is expected to be very brief.

We apologize for any inconvenience this may cause and appreciate your understanding.

Affected Services:
Affected Markets: US
Posted Sep 02, 2025 - 11:09 UTC
This incident affected: Flutterwave Collections (Checkout JS).