[Kenya] Service Alert: Disruption Affecting KES Transactions

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the intermittent disruption affecting KES collections has been successfully resolved.

Thank you for your patience and understanding.
Posted Aug 12, 2026 - 09:50 UTC

Investigating

Dear Valued Merchant,

We are currently experiencing intermittent service disruption affecting collections.

The affected service provider has been notified and is actively working to restore normal service. Some merchants may experience failed or delayed transactions during this period. We will share further updates as more information becomes available.

We apologize for the inconvenience and appreciate your patience and understanding.
Posted Aug 12, 2026 - 08:07 UTC