[Zambia] Service Restored: Intermittent Failures on Payment Collections

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with one of our external payment providers, which affected collections for some customers in Zambia has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Zambia
Posted Jun 08, 2026 - 00:37 UTC

Identified

Dear Valued Customer,

We are experiencing a temporary issue with one of our external payment providers, which may affect collections for some customers in Zambia. Our team is investigating the matter and working closely with the provider to fix it quickly. We apologize for the inconvenience and thank you for your patience.

Affected Services:
Affected Markets: Zambia
Posted Jun 07, 2026 - 06:07 UTC
This incident affected: Flutterwave Collections (Collections APIs).