[Kenya] Service Alert: Disruption Affecting KES Transactions

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with KES transactions has been successfully resolved. Thank you for your patience and understanding.
Posted Jul 28, 2026 - 10:30 UTC

Investigating

Dear Valued Merchant,

Due to an issue affecting a payment partner in Kenya, some merchants may experience difficulties processing customer payments and sending funds.

The affected service provider has been notified and is actively working to resolve the issue. We are closely monitoring the situation and will provide further updates as soon as new information becomes available.

We apologize for the inconvenience and thank you for your continued understanding.
Posted Jul 28, 2026 - 09:50 UTC