Login issues on the Flutterwave for Business (F4B) platform

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

This incident has been fully resolved. All services are back online and operating as expected.

We appreciate your patience and understanding.
Posted Jun 29, 2026 - 15:07 UTC

Update

Dear Valued Customer,

We are observing recovery of the affected services. Our engineering team continues to closely monitor the environment to ensure service stability.

We apologize for the inconvenience caused and appreciate your patience.

Affected Services:
Affected Markets: Global
Posted Jun 29, 2026 - 13:55 UTC

Identified

Dear Valued Customer,

We are currently investigating a technical issue that is preventing customers from logging into their Flutterwave for Business (F4B) accounts. Our team is actively working to restore full access as quickly as possible. We apologize for this disruption and appreciate your patience while we get this fixed.

Affected Services:
Affected Markets: Global
Posted Jun 29, 2026 - 13:30 UTC
This incident affected: Flutterwave for Business (Dashboard).