Inability to Decline Chargebacks — NGN
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Jan 08, 2022 - 18:38 UTC
Update
We are continuing to investigate this issue.
Posted Dec 31, 2021 - 14:45 UTC
Update
We are aware of continued issues affecting some merchants' ability to Decline Chargebacks.

The resolution is taking longer than expected. In the meantime - we are continuing with the resolution process currently set up to manage this issue in the interim.

Merchant should kindly send decline evidence to disputes@flutterwavego.com
Posted Dec 13, 2021 - 13:44 UTC
Investigating
We are aware of continued issues affecting the merchant's ability to Decline Chargebacks.

The team's focused on it with a communicated fix for EOD today.

Defaulted chargebacks affected by this issue will be reconciled and the merchant's balance regularised accordingly.

We shall share further updates here
Posted Dec 10, 2021 - 12:04 UTC
This incident affected: Flutterwave for Business (Chargebacks).