[Rwanda] Service Restored: MTN Transaction Issues

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption impacting RWF transactions has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted Sep 04, 2026 - 12:15 UTC

Identified

Dear Valued Merchant,

A service disruption affecting MTN Rwanda is currently impacting some payment transactions. Customers may experience difficulties making payments or delays in receiving funds. Our team is investigating the issue and working with the affected provider to restore normal service.

We sincerely apologize for the inconvenience and thank you for your continued understanding.

Affected Services:
Affected Markets: Rwanda
Posted Sep 04, 2026 - 07:05 UTC
This incident affected: Flutterwave Collections (Collections APIs).