Service Alert: Disruption Affecting Send Login and Transfers

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting Send login, transfers, and profile information has been resolved, and normal service has been restored.

We apologize for the inconvenience experienced and appreciate your continued understanding.
Posted Sep 20, 2026 - 09:30 UTC

Investigating

Dear Valued Merchant,

You may currently experience intermittent timeouts when accessing Send, completing transfers, or loading profile information. Our team is investigating the disruption and working to restore normal service. We will continue to share updates as more information becomes available.

We sincerely apologize for the disruption and appreciate your patience and understanding.
Posted Sep 20, 2026 - 08:26 UTC