Service Alert: Delayed Settlements on Flutterwave for Business (F4B)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue affecting settlements on F4B has been successfully resolved.

Thank you for your patience and understanding.
Posted Jul 31, 2026 - 09:48 UTC

Investigating

Dear Valued Merchant,

We are currently experiencing an issue affecting settlements on F4B. As a result, scheduled settlements may be delayed.

Our engineers are actively working to restore normal service as quickly as possible. We will provide further updates as more information becomes available.

We sincerely apologize for the inconvenience and appreciate your patience and understanding.
Posted Jul 31, 2026 - 09:40 UTC