Service Restored: Pay with Bank (Nigeria)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the technical issue with our Pay with Bank service has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Mar 03, 2026 - 15:36 UTC

Identified

Dear Valued Customer,

We are currently experiencing a technical issue with our Pay with Bank Transfer service. This is due to a glitch from our service provider’s end.

Some users may notice delays in name verification or payment alerts. We are working closely with the provider to fix this quickly.

Thank you for your patience.

Affected Services:
Affected Markets: Nigeria
Posted Mar 03, 2026 - 15:13 UTC
This incident affected: Flutterwave Collections (Collections APIs).