Service Restored: Mobile Money Collections (Ghana)

Incident Report for Flutterwave

Resolved

Dear All,

We are pleased to inform you that the service disruption impacting Mobile Money debit and credit transactions in Ghana has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Ghana
Posted Dec 13, 2025 - 15:01 UTC

Identified

Dear Valued Customer,

We are currently experiencing an external service disruption impacting Mobile Money debit and credit transactions in Ghana.

The technical challenge is intermittent, affecting the successful completion of some payments.

Our team is actively engaged with the third-party provider who is working urgently to restore full service. We apologize for the inconvenience and will update you shortly.

Affected Services:
Affected Markets: Ghana
Posted Dec 12, 2025 - 22:19 UTC
This incident affected: Flutterwave Collections (Checkout JS).