[Investigating] - Payments with Discover Card — NIGERIA
Incident Report for Flutterwave
Update
This is still in progress.

We are continuing to investigate this issue. No ETR yet
Posted Nov 09, 2021 - 08:12 UTC
Investigating
We are aware of current transaction failures on Discover cards.

Payment attempts will return “card not enrolled for protect buy" or "transaction failed".

This has been escalated. Kindly allow us feedback as soon as we learn more
Posted Nov 09, 2021 - 03:37 UTC
This incident affects: Collections.