[Uganda] Service Restored: Intermittent UGX Payment Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the intermittent failures on UGX transactions has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Uganda
Posted Jul 15, 2026 - 22:20 UTC

Identified

Dear Valued Merchant,

Some customers may experience intermittent failures when they attempt to make UGX payments due to a disruption affecting Airtel. We are actively working with the provider to restore normal service and will continue to share updates as more information becomes available.

We apologize for the disruption and appreciate your patience and understanding.

Affected Services:
Affected Markets: Uganda
Posted Jul 15, 2026 - 22:03 UTC
This incident affected: Flutterwave Collections (Collections APIs).