[Nigeria] Service Restored: Account Creation Issues

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with account generation due to a disruption with our external partner has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Apr 30, 2026 - 18:37 UTC

Identified

Dear Valued Customer,

We are aware that account generation is failing for some people. This is due to a disruption with our external partner. Our engineers are investigating the matter and pushing for a fix. We apologize for any inconvenience this causes.

Affected Services:
Affected Markets: Nigeria
Posted Apr 30, 2026 - 18:29 UTC
This incident affected: Flutterwave Collections (Collections APIs).