[Nigeria] Service Restored: Issues with Card Transactions

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the intermittent failures with card payments has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jun 18, 2026 - 14:01 UTC

Identified

Dear Valued Customer,

We are seeing intermittent failures with card payments due to a technical glitch on our provider's end. Some users may have trouble completing transactions or receiving OTPs. We are investigating the issue and working closely with them on a quick fix. We apologize for the inconvenience and thank you for your patience.

Affected Services:
Affected Markets: Nigeria
Posted Jun 18, 2026 - 08:54 UTC
This incident affected: Flutterwave Collections (Collections APIs).