Service Restored: Transaction Notification Delays

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the issue with delays in receiving transaction notifications has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Nov 19, 2025 - 07:32 UTC

Identified

Dear Valued Customer,

We are currently experiencing an issue that may cause delays in receiving transaction notifications.

Transactions are processing, but the delivery of the confirmation notification is impacted. This issue has been escalated to our partner, and they are actively working on a resolution.

We apologize for the inconvenience and appreciate your patience. We will share an update as soon as new information is available.

Affected Services:
Affected Markets: Nigeria
Posted Nov 18, 2025 - 23:11 UTC
This incident affected: Flutterwave Collections (Collections APIs).