SMS OTP Delivery Disruption for Mobile Money in Ghana

Incident Report for Flutterwave

Update

Dear Valued Customer,

We have identified an issue affecting OTP delivery via SMS for MoMo transactions in Ghana. Initial investigations point to our SMS provider as the source of the issue. We have escalated the matter and are currently awaiting further feedback and a resolution timeline from the provider.

We will continue to share updates as more information becomes available. Thank you for your patience.
Posted Jun 24, 2026 - 14:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 24, 2026 - 14:44 UTC
This incident affects: Flutterwave Collections (Checkout JS).