[Nigeria] Service Alert: Notification Delays

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting transaction notifications has been successfully resolved. Thank you for your patience and understanding.
Posted Jul 28, 2026 - 11:05 UTC

Investigating

We are currently experiencing a service disruption affecting transaction notifications. As a result, some customers may experience delays in receiving transaction notifications.

We are actively working with the affected provider to restore normal service as quickly as possible and will continue to share updates as more information becomes available.

We sincerely apologize for the disruption and appreciate your patience and understanding.
Posted Jul 28, 2026 - 10:25 UTC
This incident affected: Flutterwave Collections (Collections APIs).