[Nigeria] Service Alert: Intermittent Card Transaction Timeouts

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the intermittent timeouts affecting card transactions has been successfully resolved. Thank you for your patience and understanding.
Posted Jul 28, 2026 - 15:23 UTC

Investigating

Dear Merchant,

We are currently experiencing intermittent timeouts affecting card transactions processed through Interswitch. As a result, some merchants may experience failed or delayed card payments.

We are actively working with the service provider to restore normal service as quickly as possible and will continue to provide updates as more information becomes available.

We sincerely apologize for the disruption and appreciate your patience and understanding.
Posted Jul 28, 2026 - 10:23 UTC
This incident affected: Flutterwave Collections (Collections APIs).