[Nigeria] Service Restored: Issues with Name Verification

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the delays observed for name enquiries has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Apr 22, 2026 - 12:25 UTC

Update

Please note that we have switched to a backup provider to keep transactions moving. Our team is investigating and working on a fix. We apologize for the trouble.

Affected Services:
Affected Markets: Nigeria
Posted Apr 22, 2026 - 10:53 UTC

Identified

Dear Valued Customer,

We are currently seeing delays with our third-party provider for name enquiries. This may affect some users attempting collections and payouts. Our team is investigating a fix, and we are sorry for the trouble.

Affected Services:
Affected Markets: Nigeria
Posted Apr 22, 2026 - 10:40 UTC
This incident affected: Flutterwave Collections (Collections APIs).