Service Disruption Affecting Multiple Business Platforms

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

Please be informed that all our services have recovered successfully following the outage caused by Cloudflare. We apologise for all inconveniences experienced.
Thank you for understanding
Posted Nov 19, 2025 - 08:18 UTC

Monitoring

Dear Valued Customer,
We wish to inform you that our platforms are currently up and running. However, we are monitoring closely to ensure continued stability.
We apologize for the interruption and will update you immediately upon full resolution.
Posted Nov 18, 2025 - 15:46 UTC

Identified

We are currently experiencing intermittent service outages affecting multiple platforms, including Flutterwave for Business (F4B) and SEND.
This disruption is as a result of an issue with a Core Domain provider (Cloudflare).
Our engineering team is actively engaged and working to mitigate the impact and restore full stability as quickly as possible.
We apologize for any inconvenience caused. We will provide an update shortly.
Posted Nov 18, 2025 - 12:11 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave for Business (Flutterwave Sign-up, Flutterwave API, Dashboard, Virtual Cards, Settlements, Chargebacks, Bill Payments (Airtime), Bill Payments (Cable TV)).