[NGN] Service Alert: Disruption on NGN Card Collections

Incident Report for Flutterwave

Update

We are seeing an improvement in transaction success rates for NGN card transactions. We continue to closely monitor the service to ensure stability and will share further updates as progress is made.

We apologize for the inconvenience and thank you for your patience.
Posted Sep 23, 2026 - 19:52 UTC

Identified

Dear Valued Merchant,

We are currently seeing a disruption affecting some NGN card collections through Interswitch, which may prevent transactions from completing successfully. The service provider has been notified and we are working to restore normal service. Further updates will be shared as progress is made.

We apologize for the inconvenience and thank you for your patience.

Affected Services:
Affected Markets: Nigeria
Posted Sep 23, 2026 - 06:51 UTC
This incident affects: Flutterwave Collections (Collections APIs).