Service instability on Flutterwave for Business (F4B), Oct 11 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the intermittent issue affecting F4B V4 production and sandbox environments has been successfully resolved.

We are closely monitoring the situation closely to ensure continued stability.
Thank you for your patience and understanding.

Affected Services:
Affected Markets: Global
Posted Oct 11, 2025 - 15:50 UTC

Identified

Dear Valued Customer,

We are currently investigating an issue impacting the stability and availability of our business application, F4B. Customers may be experiencing intermittent errors, slower performance, or failed transactions.

Our engineering team is actively working to stabilize the environment and restore full service. We apologize for the inconvenience and will provide an update as soon as more information is available.

Affected Services:
Affected Markets: Global
Posted Oct 11, 2025 - 09:26 UTC
This incident affected: Flutterwave for Business (Flutterwave API).