Service Restored - Mobile Collections in Rwanda

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the intermittent service timeouts affecting mobile collections in Rwanda has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted Dec 08, 2025 - 21:40 UTC

Identified

Dear Valued Customer,

We are currently experiencing intermittent service timeouts affecting mobile collections in Rwanda.

This is causing some transactions to fail or process slowly. We have notified our external service partner about the issue and their engineers are working to resolve it urgently.

We apologize for any inconvenience this causes. Further updates will be provided here as soon as we have new information. Thank you for your understanding.

Affected Services:
Affected Markets: Rwanda
Posted Dec 08, 2025 - 08:14 UTC
This incident affected: Flutterwave Collections (Collections APIs).