[3rd Party Downtime] - Collection via First Bank "Pay With Bank" — NIGERIA
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Jul 30, 2021 - 02:49 UTC
Investigating
We are aware of an issue on First Bank account payment option.

Customers will get the response: "Something went wrong. Please contact support for assistance" on redirect to First Bank “firstcheckout” page to complete payment.

Resolution is underway by First Bank.

Transactions on other payment methods are processing fine.

We apologise for any inconvenience and will post another update as soon as we learn.
Posted Jul 29, 2021 - 17:54 UTC
This incident affected: Collections.