[Nigeria] Service Restored: 9PSB Recipient Name Verification Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with 9PSB Name Enquiry Service has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jul 17, 2026 - 08:07 UTC

Identified

Dear Valued Merchant,

A disruption affecting the 9PSB Name Enquiry Service is preventing some customers from confirming recipient names before completing payments.

Our team is working closely with 9PSB to resolve the issue as quickly as possible. We will keep you informed as new information becomes available.

We're sorry for the inconvenience and thank you for your continued understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jul 17, 2026 - 08:05 UTC
This incident affected: Flutterwave Collections (Collections APIs).