[USD] Service Restored: Delays affecting USD transfers

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the service disruption with USD transfers preventing some customers from completing transactions has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: US
Posted Sep 04, 2026 - 12:38 UTC

Identified

Dear Valued Merchant

Some USD transfers are currently experiencing a service disruption, which may prevent some customers from completing transactions. Our team is investigating the issue and will provide additional information as soon as they become available.

We apologize for the inconvenience and thank you for your understanding while we work to resolve this.

Affected Services:
Affected Markets: US
Posted Sep 04, 2026 - 08:18 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).