[RESOLVED] Service Alert: MTN Rwanda (Collections & Payouts)

Incident Report for Flutterwave

Resolved

Dear Valued Merchants,

Please be informed we experienced a brief service disruption on MTN Rwanda which impacted Collections and Payouts, this has been fully resolved.

We sincerely apologize for any inconvenience caused and appreciate your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted Sep 09, 2026 - 09:50 UTC
This incident affected: Flutterwave Collections (Collections APIs).