Service Restored: Intermittent Payment Delays (Ghana)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the payment timeouts issue on Mobile Money Ghana has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Ghana
Posted Feb 18, 2026 - 09:32 UTC

Identified

Dear Valued Customer,

We are aware that some customers are experiencing payment timeouts on MoMo Ghana. This is resulting from challenges at the service provider level.

The provider is working to restore full service. Thank you for your patience.

Affected Services:
Affected Markets: Ghana
Posted Feb 17, 2026 - 13:23 UTC
This incident affected: Flutterwave Collections (Checkout JS).