[GHS] Service Alert: Disruption Affecting GHS Account Generation

Incident Report for Flutterwave

Resolved

We are pleased to confirm that the issue affecting GHS account generation through FirstBank has been resolved, and normal account generation has resumed.

We apologize for the inconvenience experienced and appreciate your continued understanding.
Posted Sep 20, 2026 - 07:01 UTC

Identified

Dear Valued Merchant,

We are currently experiencing a disruption affecting some GHS account generation through FirstBank. This is impacting both dynamic and static account generation. Our teams are actively investigating the issue and working to restore normal service, with further updates to follow.

We apologize for the inconvenience and appreciate your patience and understanding.

Affected Services:
Affected Markets: Ghana
Posted Sep 19, 2026 - 10:41 UTC
This incident affected: Flutterwave Collections (Collections APIs).